TCS-CDP pro clone can’t read BMW ECU [user solution]

I have recently purchased new TSC-CDP pro from China. Software supplied with its softwware 2014 release 2. The software installed and activated OK. i tested the unit and it passed the test OK; but unluckily, it does not communicate with any car… only use USB cable ( not bothered with Bluetooth). After vehicle selection, the system cannot read ECUs and generates silly error messages “Vehicle not responding (Fahrzeug antwortet nicht)”.

Error message:
Startup
Initiation of the tester… YES
Searching for the interface… YES
Establish communication… NO
(ISO 157656-4, SAW J1939-21)
Delphi-error-no-com
Vehicle not responding
The vehicle is not responding to the diagnosis inquiry made. Please make sure that the tester is correctly connected to the vehicle and that the ignition is turned on, and try again to establish communication. If communication fails again, it is possible that the diagnosis function is not supported.
error-not-reponding
Software:
2014 release 2.
The software installed and activated OK…and tested the unit and it passed the test OK
Hardware: (new VCI), Serial No.100251, eOBD 114, Firmware version 1423.
test-OK
CDP-blue-board
* First modification- FAILED!
I tested on Mercs and BMW. I opened the CDP unit and observed that two boards are not connected correctly. So, I pushed them together. This has improved a bit, as the unit now makes a clicking noise when connected to a car. Even can read the VIN, but on BMW failed to read the ECU. I will try later on a different car. But this is already a bad news (no BMWs).

Then, I contacted the supplier and was informed that this TCS-CDP DOES NOT WORK with BMWs and Mercedes cars !!!!!

* Second modification- FAILED!
Then i was told that “the device actually does not work on any vehicle that uses SAE J1850 (PWM and VPW) because it has a fake OKI m6636 or it does not have it at all… The OKI chip is only for cars that support the PWM/VPWM protocol like Ford. BMW didn’t use the PWM/VPWM protocol.” And this user did fix the problem and used the same interface for all BMW cars..TCS CDP interface, removed from old devices like tv´s, radio´s etc. check all solder Joints of all components (especially relays)..

But I didn’t try that, and decided to purchase another TCS CDP from a different supplier. White this time… When it arrived I tested it immediately on the same BMW 7 E66… and guess what …. Same problems remained.
New TCS CDP white:
CDP-white-2-boards+cover
CDP-white-back-side
CDP-white-2-boards
***** Third modification- Successfully SOLVED finally!
the problem with the m6636 is in the cdp pro, not in cdp+. replace the 2 diodes (D701 and D703) with 1n4148. back the pcb.
CDP-blue-back-side
Then gained the communication with BMW car which I could not communicate with before.
So, well DONE!

Ps. To avoid problems above, i recommend you all to buy the OK version as my friend used, without any issues so far. you can see his PCB below. He bought this from
http://www.obd2express.co.uk/wholesale/tcs-cdp-pro-diagnostic-bluetooth-a.html
It is said that it’s the best clone CDP from China
tcs-cdp-pro-diagnostic-bluetooth-2

tcs-cdp-pro-diagnostic-bluetooth-1
(someone also said a 100% solution in mhhauto forum:
have to install
Microsoft .NET Framework 3.5
and
Microsoft .NET Framework 3.5 Service Pack 1
and all is 100%

But i didn’t tru it. Maybe it works!

TCS CDP pro+ installation reference: http://blog.obd2express.co.uk/2016/06/29/how-to-install-tsc-cdp-pro-2015r3/

FacebookTwitterGoogle+LinkedInStumbleUponIf you like this,please share it with your friends